Speakerplans.com Homepage
Forum Home Forum Home > General > Amp Forum
  New Posts New Posts RSS Feed - Amplifiers Rescue Gods
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Amplifiers Rescue Gods

 Post Reply Post Reply Page  <1 15161718>
Author
Message
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2022 at 2:59pm
You will blow the amplifier useing it without a fan...he will heat and  limit the outputs transistors always and this will make them weeker and weeker untill will blow up...the MT1200 is not made to be used without a proper cooling fan,as the heatsinks in these series are a joke compared to other amplifiers and are fully dependent of the fan air flow to get cooled properly.Confused watching at that amp now i only see a timer bomb Confused about the rubber capacitor washers,when i changed the caps i added plastic thicker washers just to be 200% sure that i will never have any problems,i made the washers from old binding posts support as there strong enaugh to tight them like hell and same screw size Big smile

Edited by EmPro - 01 July 2022 at 3:38pm
EmPro Audio
Back to Top
shaun1264 View Drop Down
Registered User
Registered User
Avatar

Joined: 06 September 2013
Location: Surrey
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote shaun1264 Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2022 at 3:44pm
As I've already mentioned I'll be putting a fan in. 
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2022 at 3:48pm
Originally posted by shaun1264 shaun1264 wrote:

As I've already mentioned I'll be putting a fan in. 

Perfect :D but...where you planning to put it? as his space now is full with that transformer Confused you need to find a different place for the transformer...as the fan needs to be in the same place...Confused
EmPro Audio
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2022 at 5:08pm
When driver boards blows up on Citronic Conquest V12:

I made this immortal lateral mosfet amplifier two years ago...still going strong and for sure i will die old and this amp will still play no problem LOLLOL not the best of my designs btw,i was just bored that time and i loved the case and heatsinks of this Citronic way to much to throw them away Big smile and yeah...the funny part is that i set the dual fan cooling sistem always on,i ask myself even today why the f_ck i even done that LOLLOL


Edited by EmPro - 01 July 2022 at 5:26pm
EmPro Audio
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 19 July 2022 at 8:15pm
One of my 6 saved HH M900 this one was the worse:


Edited by EmPro - 19 July 2022 at 8:17pm
EmPro Audio
Back to Top
djkeet View Drop Down
Registered User
Registered User
Avatar

Joined: 26 December 2011
Location: England
Status: Offline
Points: 451
Post Options Post Options   Thanks (0) Thanks(0)   Quote djkeet Quote  Post ReplyReply Direct Link To This Post Posted: 19 July 2022 at 11:57pm
Originally posted by EmPro EmPro wrote:

i couldn't save the original inscription on the front panel as it was way to rusty....right ch was dead (outputs blown) left ch working,now is fully working :) Old School Cloud GS 3002


I like how the case turned out did powder coat it or what spray did you use?
Soundbite
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 20 July 2022 at 7:12am
Originally posted by djkeet djkeet wrote:

Originally posted by EmPro EmPro wrote:

i couldn't save the original inscription on the front panel as it was way to rusty....right ch was dead (outputs blown) left ch working,now is fully working :) Old School Cloud GS 3002


I like how the case turned out did powder coat it or what spray did you use?

Black spray for cars mate :) from B&Q.


Edited by EmPro - 20 July 2022 at 7:13am
EmPro Audio
Back to Top
djkeet View Drop Down
Registered User
Registered User
Avatar

Joined: 26 December 2011
Location: England
Status: Offline
Points: 451
Post Options Post Options   Thanks (0) Thanks(0)   Quote djkeet Quote  Post ReplyReply Direct Link To This Post Posted: 20 July 2022 at 10:25pm
Originally posted by EmPro EmPro wrote:

Originally posted by djkeet djkeet wrote:

Originally posted by EmPro EmPro wrote:

i couldn't save the original inscription on the front panel as it was way to rusty....right ch was dead (outputs blown) left ch working,now is fully working :) Old School Cloud GS 3002


I like how the case turned out did powder coat it or what spray did you use?


Black spray for cars mate :) from B&Q.



Cheers
Soundbite
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 21 July 2022 at 5:22am
Cheers
EmPro Audio
Back to Top
Seca23 View Drop Down
New Member
New Member
Avatar

Joined: 08 September 2022
Location: Romania
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seca23 Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2022 at 3:09pm
Hi!
I need some help with a HH Vx1200 amp
Both the clip lights stay on, one gets a little dimmer after a few seconds after turning it on.
I already changed the lm339n comparator but it made no difference
The amp is working ok, it doesn't sound distorted at all.
Another problem is when i turn it off it makes a squeaky noise for a few seconds on both channels.
These problems apeared suddenly, it was working perfectly before.
I would also like to know the procedure for adjusting bias and dc offset

Thank you! 
Back to Top
EmPro View Drop Down
Registered User
Registered User
Avatar

Joined: 26 June 2020
Status: Offline
Points: 213
Post Options Post Options   Thanks (0) Thanks(0)   Quote EmPro Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2022 at 3:18pm
That is a common problem caused by leaky or dryed capacitors in driver board,always replace them with new ones and your problem will dissapear 100%,for bias and dc adjustments you should have trimmers (2 for each ch) with reference points for bias values Smile as far i remember from my old VX900.
EmPro Audio
Back to Top
Seca23 View Drop Down
New Member
New Member
Avatar

Joined: 08 September 2022
Location: Romania
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seca23 Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2022 at 3:22pm
I can't find the test points and I don't know the corect value for bias
Back to Top
 Post Reply Post Reply Page  <1 15161718>

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.05
Copyright ©2001-2022 Web Wiz Ltd.

This page was generated in 0.174 seconds.