Speakerplans.com Homepage
Forum Home Forum Home > General > Newbie Discussion
  New Posts New Posts RSS Feed - Citronic Thames 2
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Citronic Thames 2

 Post Reply Post Reply
Author
Message
Steve Jones View Drop Down
New Member
New Member


Joined: 03 February 2022
Location: Chester
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve Jones Quote  Post ReplyReply Direct Link To This Post Topic: Citronic Thames 2
    Posted: 03 February 2022 at 9:22pm
I wonder if anyone has a circuit diagram and user manual for a Citronic Thames 2. I bought the unit in 1988. The problem that I have is that there is no sound out of the left channel


Back to Top
Monitech View Drop Down
Registered User
Registered User
Avatar

Joined: 19 February 2008
Location: United Kingdom
Status: Offline
Points: 76
Post Options Post Options   Thanks (0) Thanks(0)   Quote Monitech Quote  Post ReplyReply Direct Link To This Post Posted: 04 February 2022 at 8:56am
Two things to try are clean the send and return sockets, and the speaker outputs, these parts will be worn-out 
phoenix out of the ashes
Back to Top
Steve Jones View Drop Down
New Member
New Member


Joined: 03 February 2022
Location: Chester
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve Jones Quote  Post ReplyReply Direct Link To This Post Posted: 04 February 2022 at 4:29pm
Thanks for your reply but surely the send and return sockets wouldn't affect  the channels from the record decks? Or would it? Also there is only one channel if I put the media player in the auxillary or external tape socket
Back to Top
jbl_man View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 12 January 2005
Location: London.
Status: Offline
Points: 11001
Post Options Post Options   Thanks (0) Thanks(0)   Quote jbl_man Quote  Post ReplyReply Direct Link To This Post Posted: 04 February 2022 at 6:39pm
Do you have sound on both channels using the headphones? If yes, then the fault is with the left-hand amp module. If no, then it's a mixer fault. Check the op-amps, as these can be a common fault.
Be seeing you.
Back to Top
Steve Jones View Drop Down
New Member
New Member


Joined: 03 February 2022
Location: Chester
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve Jones Quote  Post ReplyReply Direct Link To This Post Posted: 04 February 2022 at 6:45pm
I'm using stereo headphones but sound only comes out of both when the jack plug is not fully plugged in. Excuse my ignorance but what are the "op amps" and how would I check them ?
Back to Top
Steve Jones View Drop Down
New Member
New Member


Joined: 03 February 2022
Location: Chester
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve Jones Quote  Post ReplyReply Direct Link To This Post Posted: 04 February 2022 at 6:46pm
Also the sound comes out of both speaker terminals
Back to Top
jbl_man View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 12 January 2005
Location: London.
Status: Offline
Points: 11001
Post Options Post Options   Thanks (0) Thanks(0)   Quote jbl_man Quote  Post ReplyReply Direct Link To This Post Posted: 05 February 2022 at 8:59am
"I'm using stereo headphones but sound only comes out of both when the jack plug is not fully plugged in"

That is because the jack plug needs to be fully in, so we can assume that one channel of the mixer is not working.
Ok, with the headphone plug fully in, are you missing a channel on every input? Ie, the same channel is dead on both turntables and aux inputs as well?
Be seeing you.
Back to Top
Steve Jones View Drop Down
New Member
New Member


Joined: 03 February 2022
Location: Chester
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve Jones Quote  Post ReplyReply Direct Link To This Post Posted: 07 February 2022 at 1:16pm
The same channel is not working on both turntables and auxillary inputs aswell. Although the other day for a few minutes both channels appeared to work for about ten minutes on the external tape input (I think)
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.05
Copyright ©2001-2022 Web Wiz Ltd.

This page was generated in 0.078 seconds.