Speakerplans.com Homepage
Forum Home Forum Home > General > Amp Forum
  New Posts New Posts RSS Feed - Crown XS1200 Amplifier PIC Controller
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Crown XS1200 Amplifier PIC Controller

 Post Reply Post Reply Page  <123>
Author
Message
CaptenMorgan View Drop Down
New Member
New Member


Joined: 28 December 2016
Location: Limnos
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote CaptenMorgan Quote  Post ReplyReply Direct Link To This Post Posted: 28 December 2016 at 8:22pm
hi guys       
I have 2 crown amps   xs900 and xs1200 for repear . on xs900 the pic 16c57 is damaged.
I need the hex to program a new pic .Is the same hex with above Pulse 2x1100? .can I use it?
Back to Top
TMH Music View Drop Down
Registered User
Registered User
Avatar

Joined: 07 April 2011
Location: London
Status: Offline
Points: 450
Post Options Post Options   Thanks (0) Thanks(0)   Quote TMH Music Quote  Post ReplyReply Direct Link To This Post Posted: 28 December 2016 at 11:53pm
Sorry to hijack this thread, but as the owner of an XS1200, I am curious as to people's opinion on the reliability of this amp. Is this PIC controller problem a known fault? Any advice on how to keep this amp reliable would be gratefully appreciated.
Nothing is foolproof because fools are so ingenious
Back to Top
ceharden View Drop Down
The 10,000 Points Club
The 10,000 Points Club
Avatar

Joined: 05 June 2005
Location: Southampton
Status: Offline
Points: 11094
Post Options Post Options   Thanks (0) Thanks(0)   Quote ceharden Quote  Post ReplyReply Direct Link To This Post Posted: 29 December 2016 at 12:37am
Failure of the PIC controller is fairly uncommon.  I've only seen one myself on an original Pulse.

Biggest tips for keeping any amp reliable are keep them clean and dry and don't drive them hard into low impedance loads.  Although the Pulses/XS Series are rated for 2Ohm operation, I wouldn't.  They are best suited for mid-top applications which they sound very good on.
Back to Top
CaptenMorgan View Drop Down
New Member
New Member


Joined: 28 December 2016
Location: Limnos
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote CaptenMorgan Quote  Post ReplyReply Direct Link To This Post Posted: 29 December 2016 at 7:00am
In my case the  pic falure cased by 5v supply. A bc546 sorted and pass 30v to pic.
xc900 and xs1200 is exactly the same exept some smaller power supply capasitors. Can i use this Hex?
xc1200 and pulse use the same Hex?  I mast be sure.
thanks
Back to Top
kedwardsleisure View Drop Down
Old Croc
Old Croc


Joined: 20 January 2009
Location: Staffordshire
Status: Offline
Points: 3907
Post Options Post Options   Thanks (0) Thanks(0)   Quote kedwardsleisure Quote  Post ReplyReply Direct Link To This Post Posted: 29 December 2016 at 6:21pm
you'll need the firmware version, it'll be printed on the label on the micro.
K. Edwards Electronics Engineers

North Staffordshire

Back to Top
simonp1100 View Drop Down
Young Croc
Young Croc
Avatar

Joined: 01 September 2008
Location: Bristol
Status: Offline
Points: 698
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonp1100 Quote  Post ReplyReply Direct Link To This Post Posted: 29 December 2016 at 7:09pm
Hi,

PIC's info marked on them is as follows:--

Crown XS1200 = REV.:1.09 (CS.: 8778).
C-Audio Pulse 4 X 300 = (RX5066 V1.06).

I think (correct me if i am wrong) but software RX5066V106 is for the 4 channel amps & RX5066V107 is for the 2 channel amps. Hope this info helps.






Back to Top
jacethebase View Drop Down
Old Croc
Old Croc
Avatar

Joined: 23 September 2009
Location: Somerset
Status: Offline
Points: 4897
Post Options Post Options   Thanks (0) Thanks(0)   Quote jacethebase Quote  Post ReplyReply Direct Link To This Post Posted: 29 December 2016 at 10:30pm
I have loads of Pulses and a fair few XS1200's and 700's all mine are fairly reliable and sound great on wedges.
www.deltastarevents.com

www.dss-audio.co.uk
Back to Top
CaptenMorgan View Drop Down
New Member
New Member


Joined: 28 December 2016
Location: Limnos
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote CaptenMorgan Quote  Post ReplyReply Direct Link To This Post Posted: 30 December 2016 at 1:31am
both amps  xs 1200 xs900 have the same version   rev109 cs 8778  . 
 you think RX5066V107 is  ok to  me or is only for 2 channel pulse ?
Back to Top
simonp1100 View Drop Down
Young Croc
Young Croc
Avatar

Joined: 01 September 2008
Location: Bristol
Status: Offline
Points: 698
Post Options Post Options   Thanks (1) Thanks(1)   Quote simonp1100 Quote  Post ReplyReply Direct Link To This Post Posted: 30 December 2016 at 8:00am
I would use the RX5066V107 software. Wink
Back to Top
CaptenMorgan View Drop Down
New Member
New Member


Joined: 28 December 2016
Location: Limnos
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote CaptenMorgan Quote  Post ReplyReply Direct Link To This Post Posted: 01 January 2017 at 11:45am
ok
thanks to you  one amp have a chanse to return fron the land of dead amps Tongue
Back to Top
kedwardsleisure View Drop Down
Old Croc
Old Croc


Joined: 20 January 2009
Location: Staffordshire
Status: Offline
Points: 3907
Post Options Post Options   Thanks (0) Thanks(0)   Quote kedwardsleisure Quote  Post ReplyReply Direct Link To This Post Posted: 01 January 2017 at 2:05pm
I have V1.09 if you need it
K. Edwards Electronics Engineers

North Staffordshire

Back to Top
CaptenMorgan View Drop Down
New Member
New Member


Joined: 28 December 2016
Location: Limnos
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote CaptenMorgan Quote  Post ReplyReply Direct Link To This Post Posted: 01 January 2017 at 3:31pm
can you send me or give download ling ,please?
Back to Top
 Post Reply Post Reply Page  <123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.047 seconds.