Speakerplans.com Homepage
Forum Home Forum Home > General > Electro Frying Forum
  New Posts New Posts RSS Feed - how did this happen?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

how did this happen?

 Post Reply Post Reply Page  <123>
Author
Message
djkeet View Drop Down
Registered User
Registered User
Avatar

Joined: 26 December 2011
Location: England
Status: Offline
Points: 248
Post Options Post Options   Thanks (0) Thanks(0)   Quote djkeet Quote  Post ReplyReply Direct Link To This Post Posted: 06 January 2012 at 11:20pm
I think I would also change the resistors as well to a higher voltage with a metal heatsink as oppose to the ceramic body type
Back to Top
wayward91 View Drop Down
Young Croc
Young Croc


Joined: 15 July 2010
Location: Leeds/Mancester
Status: Offline
Points: 674
Post Options Post Options   Thanks (0) Thanks(0)   Quote wayward91 Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 12:10am
one of my rcf monitors has a similar kind of thing happening. i cant decide if its from mechanical shock only or overdriving it. there seems to be a small surface chip and a surface hairline crack a few inches long coming from it. i have driven them pretty hard in the past with about 400wrms near clip for a few hours.
should i be concerned ?
Back to Top
cravings View Drop Down
Old Croc
Old Croc
Avatar

Joined: 30 January 2007
Location: Ireland
Status: Offline
Points: 6473
Post Options Post Options   Thanks (0) Thanks(0)   Quote cravings Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 11:55am
the magnet is cracked but the driver still works ok?
Back to Top
cravings View Drop Down
Old Croc
Old Croc
Avatar

Joined: 30 January 2007
Location: Ireland
Status: Offline
Points: 6473
Post Options Post Options   Thanks (0) Thanks(0)   Quote cravings Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 11:56am
to follow up on this, i've ordered a pair of BMS 12s320 from tony. it looks like they'll only just fit exactly.. from what i can work out anyway. will follow up when they arrive how i go.
Back to Top
wayward91 View Drop Down
Young Croc
Young Croc


Joined: 15 July 2010
Location: Leeds/Mancester
Status: Offline
Points: 674
Post Options Post Options   Thanks (0) Thanks(0)   Quote wayward91 Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 1:43pm
ye the magnet is craked but it works. i opened the cab because there was intermitent minor distortion from the woofer. i have touched up all the solder joints on the crossover and it seems to be fine now but i guess it could have been that ?
Back to Top
service dept Steve View Drop Down
Old Croc
Old Croc


Joined: 30 January 2010
Location: S.W.London
Status: Offline
Points: 1952
Post Options Post Options   Thanks (0) Thanks(0)   Quote service dept Steve Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 2:57pm
Sorry to barge in but the clue was at the beginning, This is from a monitor and so therefore it is simple: it has been dropped off the stage. No hot, no overdrive, no distorted signal, just deceleration trauma. Find out who was in charge and give them the bill.
We are not "They", We are "The others"http://www.servicedept.co.uk -
Back to Top
wayward91 View Drop Down
Young Croc
Young Croc


Joined: 15 July 2010
Location: Leeds/Mancester
Status: Offline
Points: 674
Post Options Post Options   Thanks (0) Thanks(0)   Quote wayward91 Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 3:36pm
Originally posted by service dept Steve service dept Steve wrote:

Sorry to barge in but the clue was at the beginning, This is from a monitor and so therefore it is simple: it has been dropped off the stage. No hot, no overdrive, no distorted signal, just deceleration trauma. Find out who was in charge and give them the bill.


not sure if this was regarding my post but if its is , i left a small detail out. its a diddy rcf monitor 8 LOL i have made a pole mount adaptor for them and used them to do a small pub event (very small pub) .


Edited by wayward91 - 07 January 2012 at 3:38pm
Back to Top
Dub Specialist View Drop Down
Old Croc
Old Croc
Avatar

Joined: 30 December 2011
Location: Smethwick
Status: Offline
Points: 3230
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dub Specialist Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 4:01pm
Originally posted by cravings cravings wrote:

checked a pair of turbosound txd12m monitors yesterday.. one of them sounded totally terrible.. investigation revealed this....







the magnet has totally split. there's damage to the crossover board too... melted wadding around the big coil, and one of the capacitors has literally exploded.

what would have caused all this to happen? the driver still reads ok on the meter, and some sound muffles its way out of it.. but the coil is totally trapped in the broken magnet.

i'm sure i remember seeing a post by someone (peter moller maybe? maybe not..) who had the crossover in one of these boxes go on fire.. but i can't find that now.

and also what to do. i've looked on the board and someone said the LS1219 driver is actually a p-audio E12-200atw... does anyone know if this is true, or the cheapest way to get this speaker back to normal quickly?

thanks..
 
stick to Sound Lab dont happen to them..lolLOL
Back to Top
mrspeedy View Drop Down
Young Croc
Young Croc
Avatar

Joined: 23 July 2011
Location: Cambridge UK
Status: Offline
Points: 511
Post Options Post Options   Thanks (0) Thanks(0)   Quote mrspeedy Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 4:55pm
Thats because the only magnet on a Soundlab is similar to that of a souvenir fridge magnet from Malawi. 
Back to Top
cravings View Drop Down
Old Croc
Old Croc
Avatar

Joined: 30 January 2007
Location: Ireland
Status: Offline
Points: 6473
Post Options Post Options   Thanks (0) Thanks(0)   Quote cravings Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2012 at 7:11pm
i dont think it's just physical trauma. that's 4 of these turbo drivers in these cabs i know of ending up like this. my 2 (different incidents), one belonging to the guy i bought the boxes from, and one on psw someone mentioned.

anyway. gonna see how the replacements go.. if they fit.
Back to Top
cravings View Drop Down
Old Croc
Old Croc
Avatar

Joined: 30 January 2007
Location: Ireland
Status: Offline
Points: 6473
Post Options Post Options   Thanks (0) Thanks(0)   Quote cravings Quote  Post ReplyReply Direct Link To This Post Posted: 13 March 2012 at 7:49pm
they don't.

it's actually the top hat is stopping them from fitting.. and the way the top hats are mounted is a bit tricky... removing them may end up a bit destructive.

not sure what to do really with them now.. could really do with them working again..

also have a pair of the bms12s320 now to do something with.. wondering if they'll work in a single smt cab..
Back to Top
soundguymatt View Drop Down
Young Croc
Young Croc


Joined: 25 August 2009
Status: Offline
Points: 681
Post Options Post Options   Thanks (0) Thanks(0)   Quote soundguymatt Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2013 at 11:08pm
What happened with your boxes in the end? 

--

Matt
Back to Top
 Post Reply Post Reply Page  <123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.078 seconds.