Speakerplans.com Homepage
Forum Home Forum Home > General > Amp Forum
  New Posts New Posts RSS Feed - possible qsc rmx amp problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

possible qsc rmx amp problem

 Post Reply Post Reply Page  12>
Author
Message
zigzagwanderer View Drop Down
Registered User
Registered User


Joined: 01 February 2021
Location: sw uk
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote zigzagwanderer Quote  Post ReplyReply Direct Link To This Post Topic: possible qsc rmx amp problem
    Posted: 19 April 2022 at 8:34pm
just bought 2x QSC RMX 4050 amps - the clip light on one channel of one of the amps doesn't illuminate on switch on, nor does it illuminate when i try to drive it into clip. the channel's audio appears to be fine, 

we switched the channel connectors over to test the clip LEDs and both have worked so its not the LED itself.
anyone know what this could be?
Back to Top
Conanski View Drop Down
Old Croc
Old Croc
Avatar

Joined: 26 January 2006
Location: Canada
Status: Offline
Points: 2254
Post Options Post Options   Thanks (0) Thanks(0)   Quote Conanski Quote  Post ReplyReply Direct Link To This Post Posted: 19 April 2022 at 10:10pm
Did you check and then cycle the dip switches on the back even if they looked like they were set correctly?

Edited by Conanski - 19 April 2022 at 10:18pm
Back to Top
zigzagwanderer View Drop Down
Registered User
Registered User


Joined: 01 February 2021
Location: sw uk
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote zigzagwanderer Quote  Post ReplyReply Direct Link To This Post Posted: 20 April 2022 at 12:16am
Ok... 3 hours later, figured it out...
Was a faulty connector cable between the main boards and the pcb with the pots and LEDs.

Back to Top
Line Array View Drop Down
Registered User
Registered User


Joined: 19 March 2022
Location: New Jersey, USA
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Line Array Quote  Post ReplyReply Direct Link To This Post Posted: 20 April 2022 at 8:38am
Originally posted by zigzagwanderer zigzagwanderer wrote:

Ok... 3 hours later, figured it out...
Was a faulty connector cable between the main boards and the pcb with the pots and LEDs.


ironic because QSC amps don't use a lot of ribbon cables, connectors etc.

seems prudent to look for amps that only use the bare minimum number of internal cables, connectors etc.

my old QSC PLX is failing at the volume knob pots which sound kind of rusty with sound occasionally dropping out until you fiddle with them a little - those are something i would avoid too if possible.  if it's possible to have volume control entirely in the digital domain or at least without any kind of physical contacts that can go bad.

basically eliminate as many contacts as possible.

what are the most failure prone components in an amp ?

it's probably contacts followed by capacitors and power devices only when overdriven or under-cooled.

does that sound about right ?  

what makes an amp reliable ?
best place on the internet >>>

https://dissidentsound.discoursehosting.net
Back to Top
RoadRunnersDust View Drop Down
Registered User
Registered User
Avatar

Joined: 03 December 2013
Location: United Kingdom
Status: Offline
Points: 389
Post Options Post Options   Thanks (0) Thanks(0)   Quote RoadRunnersDust Quote  Post ReplyReply Direct Link To This Post Posted: 21 April 2022 at 3:21pm
Originally posted by Line Array Line Array wrote:

QSC amps don't use a lot of ribbon cables, connectors etc.


But when they do they are utter poo (reference the 1st generation PLX series)
Back to Top
zigzagwanderer View Drop Down
Registered User
Registered User


Joined: 01 February 2021
Location: sw uk
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote zigzagwanderer Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 12:49pm
ok , further to my previous post 
I botched the faulty cable to check it worked ok and I now need a replacement cable 
I think I need a 6 pin female to female JST cable approx 100mm long , the pins are 2.5mm centres.
I've looked everywhere I can think of and can't find a suitable cable available in the UK anywhere 
If possible I'd prefer not to have to make it up and have to buy a crimping tool etc  
Anyone know where I can source one , the proper QSC one would be nice but I'm not overly fussed as long as its ok quality  


Edited by zigzagwanderer - 23 April 2022 at 12:51pm
Back to Top
RoadRunnersDust View Drop Down
Registered User
Registered User
Avatar

Joined: 03 December 2013
Location: United Kingdom
Status: Offline
Points: 389
Post Options Post Options   Thanks (0) Thanks(0)   Quote RoadRunnersDust Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 1:13pm
Could you just solder wires onto the pins? (You can usually pull the plastic housing off the PCB leaving the pins like solder turrets)
Back to Top
zigzagwanderer View Drop Down
Registered User
Registered User


Joined: 01 February 2021
Location: sw uk
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote zigzagwanderer Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 1:28pm
Originally posted by RoadRunnersDust RoadRunnersDust wrote:

Could you just solder wires onto the pins? (You can usually pull the plastic housing off the PCB leaving the pins like solder turrets)

Fare point but that would make servicing the pots etc at a later date more difficult as Id have to unsolder the wires to be able to remove the the pcb with the pots on 


Back to Top
simonp1100 View Drop Down
Young Croc
Young Croc
Avatar

Joined: 01 September 2008
Location: Bristol
Status: Offline
Points: 1049
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonp1100 Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 1:58pm
Originally posted by zigzagwanderer zigzagwanderer wrote:

ok , further to my previous post 
I botched the faulty cable to check it worked ok and I now need a replacement cable 
I think I need a 6 pin female to female JST cable approx 100mm long , the pins are 2.5mm centres.
I've looked everywhere I can think of and can't find a suitable cable available in the UK anywhere 
If possible I'd prefer not to have to make it up and have to buy a crimping tool etc  
Anyone know where I can source one , the proper QSC one would be nice but I'm not overly fussed as long as its ok quality  

Found this within 5 minute search:


WinkWinkLOL
Back to Top
RoadRunnersDust View Drop Down
Registered User
Registered User
Avatar

Joined: 03 December 2013
Location: United Kingdom
Status: Offline
Points: 389
Post Options Post Options   Thanks (0) Thanks(0)   Quote RoadRunnersDust Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 2:04pm
Pots on an RMX? You mean there‚Äôs something else to do with them other than short the wiper to the input? LOL
Back to Top
zigzagwanderer View Drop Down
Registered User
Registered User


Joined: 01 February 2021
Location: sw uk
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote zigzagwanderer Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 2:35pm
Originally posted by simonp1100 simonp1100 wrote:

Originally posted by zigzagwanderer zigzagwanderer wrote:

ok , further to my previous post 
I botched the faulty cable to check it worked ok and I now need a replacement cable 
I think I need a 6 pin female to female JST cable approx 100mm long , the pins are 2.5mm centres.
I've looked everywhere I can think of and can't find a suitable cable available in the UK anywhere 
If possible I'd prefer not to have to make it up and have to buy a crimping tool etc  
Anyone know where I can source one , the proper QSC one would be nice but I'm not overly fussed as long as its ok quality  

Found this within 5 minute search:


WinkWinkLOL

Now why couldn't I find that Confused
Thank you 
Back to Top
Line Array View Drop Down
Registered User
Registered User


Joined: 19 March 2022
Location: New Jersey, USA
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Line Array Quote  Post ReplyReply Direct Link To This Post Posted: 23 April 2022 at 7:23pm
my PLX pots are not doing too well ...

could you put in an on/off switch in place of them rather than shorting ?

to act as a mute button ?

or would the transient be too loud ?

also do all pots suffer this fate or not ?

the pot on my Benchmark DAC ( a home / studio product ) is only faring slightly better than the QSC one - they're both about 15 years old ... Benchmark is considered very high quality yet still has this problem

i wonder if there are some known ways to adjust volume that aren't so problematic.  i don't mean to revive my PLX but for future purchases.

for example if you control the volume digitally - will you lose bits of resolution ?  or is it irrelevant with 24 bits having more resolution than amp has noise floor ?


Edited by Line Array - 23 April 2022 at 7:26pm
best place on the internet >>>

https://dissidentsound.discoursehosting.net
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.05
Copyright ©2001-2022 Web Wiz Ltd.

This page was generated in 0.109 seconds.